Discussion in 'OpenFormat' started by manfred_VI, Mar 6, 2008.

  1. manfred_VI

    manfred_VI New Member

    Hallo,
    also ich bin Neueinsteiger bei Eurer LogView Software. Habe aber diverse Probleme.
    - LV 2.0 mit FIX installiert. leider finde ich nirgendwo eine OpenFormat.ini!!
    Wo soll die sein???

    - Versuche mit einer abgewandelten TestLogger.ini bekomme ich nicht zum Laufen, bzw. ich scheitere vermutlich am vom LV zu erwartenden Datenformat.
    Ein versuchtes Datenformat wird vom LV zwar eingelesen und verarbeitet (im debug logfile mit Ansicht/Experte/debuglogging kommt jedenfalls keine Fehlermeldung) aber es wird nichts angezeigt - auch im LiveView Window rührt sich nichts.

    Ich komme leider nicht weiter weil mir vermutlich einige Grundlagen fehlen:
    Hab das Forum schon rauf und runter gelesen aber mir ist noch einiges unklar:
    Wie muß das Datenformat genau aussehen?
    - Muß die Ziffernanzahl für jeden Wert genau stimmen?
    - Brauche ich die führenden Nullen?
    - Kann ich Werte zwischen den Delimitern einfach rauslassen?
    - Ist der Delimiter vor der Prüfsumme nun ein ; oder ein # ?
    - Warum meckert das debuglogging nicht nach dem Empfang des Datenpacketes? Das Datenpacket wird in ASCII und Hex dargestellt, er meldet dass weiterverarbeitet wird, aber nichts tut sich.

    Seufz, Vielleicht kann mir mal einer ein funktionierendes Beispiel- Datenpacket mit einer dazu passenden OpenFormat.INI Datei schicken.

    Vielen Dank manfred
  2. Dominik

    Dominik Administrator Staff Member

    Moin !

    Ich bin derzeit iun München und fahre morgen mit dem Zug retour nach Hause. Werde in den 4h mal ein paar Infos zusammenstellen bezüglich OpenFormat und dem OF Editor welcher die INIs generiert. :)
  3. manfred_VI

    manfred_VI New Member

    Juhuuu es läuft.

    :) Super es läuft.

    nachdem ich noch an meiner zur OpenFormat.ini abgewandelten testlogger.ini rumprobiert habe (hab irgendwo im Forum doch noch eine OpenFormat.ini gefunden) kam zwar noch ein convert-Error.
    Aber nachdem ich dann im Datenprotokoll zwischen den Seperatoren noch ...;0;0;0 eingetragen habe läuft es nun.
    sieht jetzt so aus:
    '$1;1;811;0;0;0;0;0;0;256;0<CR><LF>'

    ;811; ist die Zeit und ;256; ein Meßwert
    Eine gute Basis für meine weiteren Tests.
  4. Dominik

    Dominik Administrator Staff Member

    Moin !

    Warte die News morgen ab und du bekommst einen noch besseren AHA Effekt ;)
  5. Dominik

    Dominik Administrator Staff Member

Share This Page