Discussion in 'Opencharge' started by MalteS, Mar 6, 2007.

  1. MalteS

    MalteS Member

    Hm seltsam. Während mein Ergebniss das ist was ich aufgrund des Spannungsteilers erwartet hätte passt deins da nicht so ganz ins Raster. Hast du zufälltig auch mal die Eingangsspannung am ADC gemessen?

    Ach so noch ne Frage: T8 (IRF3205) muss nach meinem bescheidenen Verständiniss nicht am Kühlkörper sitzen, oder?

    Gruß
    Malte
  2. Space

    Space New Member

    Ja, die Eingangsspannung als auch die Referenzspannung habe ich direkt am ADC gemessen. Beide Spannungen sind entsprechend dem Spannungsteiler bzw. der Referenzdiode. Wie gesagt, in das Phänomen habe ich einige Stunden gesteckt und keine Erklärung gefunden.

    T8 meinst du glaube ich nicht. T8 ist ein SUP75P03 für den Stepdownwandler und wird (im Schaltbetrieb) ordentlich warm.
  3. MalteS

    MalteS Member

    Hi Thomas,

    Hast recht. Ich meine T10
    (Verpolungsschutz Akku)

    Gruß
    Malte
  4. MalteS

    MalteS Member

    Hi,

    btw: ich habe mal meine Schematics und die Boards auf den Wikiserver geladen (zu finden unter Downloads)
    (Thomas aus Organisationsgründen wäre es wohl besser das irgendwie zu trenen, oder?)

    btw II:
    Ich habe ein neues Layout des Leistungsteils fast fertig. Das bietet dann Platz für die Spule und ist so aufgebaut das man es in ein Gehäuse bauen könnte. Lässt sich dann kein einseitiges Platinenlayout mehr realisieren. Ausserdem ist es z.T. in SMD.

    Gruß
    Malte
  5. MalteS

    MalteS Member

    Hi,

    und noch eine finale Frage: Wie werden die FETs in dem Gehäuse eigentlich gekühlt? Sind die einfach an die Gehäusewand geschraubt?

    Malte
  6. Frogger

    Frogger New Member

    Jain, die Fets sind über ein Aluwinkel mit der Gehäusewand verschraubt. Die Gehäusewand ist ja mit Einschüben für die Platine und die Kontaktfläche wird durch den Aluwinkel vergrößert.
    Schau am besten mal in die Aufbauanleitung, ich finde das man das da auf den Bildern recht gut erkennen konnte.
    Werde deine Pläne gleich mal saugen und dann bei gelegenheit mal näher beurgrunzen.
  7. Space

    Space New Member

    Ich denke man sollte auf der Downloadseit eine kleine optische Trennung reinbringen und mit ein Link auf diesen Thread verweisen.

    SMD; lass es doch auf SMD....


    Kühlung; das hat Frogger gut beschrieben. Die Verschraubung erfolgt bei mir nicht direkt über die TOxxx Gehäuselöcher sondern über eine Klemmung bei der die Verschraubung des "Klemmbalkens" durch die Zwischenräumen der Transitoren läuft.


    T10 bleibt mit besten Falle mit 0,8 Watt Wärmelast relativ kühl. Allerdings wird T10 nur mit 5V Gatespannung angesteuert. Es wird wohl so sein, daß der Optimale Rds von 8mOhm nicht erreicht wird und die Wärmelast deutlich höher als 0,8W liegt. Eine Wärmeabfuhr würde ich schon vorsehen. Auch unter dem gesichtspunkt das 10A Limit des Ladestrom noch anzuheben.


    Thomas
  8. MalteS

    MalteS Member

    Hi Thomas,

    das mit den 5V hatte ich auch als Problem identifiziert. Ich habe jetzt mal sicherheitshalber 2 untergebracht, wobei man die auch am Gehäuse montieren könnte.
    Die Platine muss in SMD bleiben. Schon weil ich der Meinung bin das sich das schneller aufbauen lässt. Im Prinzip ist jetzt der gesamte Leistungsteil auf einer Platine. Wenn man möchte könne man noch versuchen den ATMEGA (vieleicht den 32kB Typen) und den MAX110 auf der Platinen Rückseite unter die Speicherspule zu legen. Dann ließe sich der Lader doppelseitig (Platine und Bestückung) auf einer halben Europlatine realisieren.
    Ich setze das aber nicht mehr um... :)
    Denke ich werde das Layout heute abend hier reinstellen.

    Gruß
    Malte
  9. MalteS

    MalteS Member

    So unter Downloads ist auf'm Wiki Server nun auch das andere Layout zu finden.
    Hab da auch eine kleine Trennung eingebaut

    Gruß
    Malte
  10. Space

    Space New Member

    Huhu Malte,

    bin eben erst zum anschauen des Layout gekommen....
    Habe ich das richtig verstanden, von dem von dem neuen alternativen Leistungsteil gibt es auch schon ein Layout (brd)? In dem ZIP ist da nichts drinne..

    Mir ist aufgefallen, in der Datei OpenchargeLeistungsteil_v01.brd/sch sind die 75P03 fälschligerweise als Wandlerfets eingezeichnet.

    Ansonsten hat Eagle eindeutig die hübscheren Schaltpläne als Target. Auch das Routing sieht deutlich strukturierter aus. Masseführung habe ich jetzt aber nich extra angescheut.
    Ist das der Autorouter von Eagle gewesen und/oder wie hoch ist der manuelle Anteil?
  11. MalteS

    MalteS Member

    Hallo Thomas,

    jepp stimmt, ich habe beim zippen irgendwie das Board vergessen :eek:)
    ... Ich setzte mich gleich an den anderen Rechner, denke in 10min habe ich das korrigiert.


    Das mit den SUP75... ist mir beim neuzeichnen auch aufgefallen. In der neuen Variante ist das korrigiert. Mein Board habe ich auch mit den IRF3205 aufgebaut. k.A. was da schiefgelaufen ist. Ich stelle nochmal eine korrigierte Version online

    Die Masseflächen sieht man erst wenn man einmal Rastnest ausführst (Butten irgendwo unten links). Die werden automatisch um die Leiterbahnen gelegt. Routing ist übrigens alles Handarbeit, Eagle light hat keinen Autorouter.

    Gruß
    Malte
  12. Frogger

    Frogger New Member

    Hmm auch wenn es hier nicht wirklich der richtige Thread ist. Aber da es hier erwähnt wurde schreib ich es hier mal mit rein.
    Habe gerade das pdf mit den Änderungen der Platine gesehen. Da ziehst du die Displaymasse bis an den Massestern zurück. Das geht auch einfacher. Ich habe das bei mir an der selben stelle durchtrennt aber dann einfach eine Verbindung zur nebenan liegenden Masseleitung gemacht. Das Display kann da ja eh drauf, die Beleuchtung zieht nicht viel Strom und ist zudem noch konstant und der Summer wird ja auch nichtmal über einen Transistor angesteuert sondern hat noch einen Vorwiderstand. Funktioniert bei mir einwandfrei. Kannst du vor allem in einer neuen Leiterplattenversion ganz leicht ohne großen Aufwand umrouten.
    Gruss Carsten
  13. Space

    Space New Member

    Hy Carsten,
    danke für deinen Tip.
    Ich hatte ein wenig Sorge, das es die Masse versaubeutelt. Das ist dann wohl unbegründet.:)
  14. Space

    Space New Member

    @Malte
    Welchen Status hat das brd File?
    Nachbaubar, Beta Entwurf oder Baustelle.
    Ich stehe mit der Bedienphilosopie von Eagle echt auch Kriegsfuss, kann also sein das ich mich irre....aber die 2 IRF1404 in der Mitte des Boards kann ich nicht zuordnen. Und die Anschlüsse auf dem Board für die 2 IRF1404 unten links, sehen für mich sehr merkwürdig aus. Ist das eine 3 Layer Platine dunkel Blau, hell Blau und Rot?

    Kann man die beiden Boards, also Leistung und Steuerung so designen, daß wenn man die nebeneinander scheibt man ohne Verkabelung die Boards mithilfe Lötbrücken verbinden kann ?
  15. MalteS

    MalteS Member

    Hallo Thomas,

    du meinst das neue Board richtig?

    Also ich habe das noch nicht nachgebaut. Allerdings ist das Schematic das gleiche so das ich el. Fehler eher ausschliessen würde. Der Eagle Design rule check sieht m.E. auch gut aus. Es ist an einigen Stellen evtl. nicht ganz ohne weil da mal auch mal eine Leiterbahn unter einem SMD Widerstand durchgeht. Bei deinem Gehäuse würde ich mir den Abstand der Mosfets zum Leiterplattenrand ansehen. Du musst die Platine noch in die Schiene schieben, oder?
    Die Layer kannst du bei Eagle mit dem Knopf oben links in der linken! Symbolleiste abwählen. Top und Bottom muss man sich getrennt ansehen sonst checke ich das auch nicht. Oder aber das Board öffnen und kein Rastnest ausführen. Das ist bei Eagle nen bisschen blöd (oder ich kann es schlicht nicht).
    Das neue Board hat übrigens einen Teil der Signale an der Stirnseite. Ich plane das Redesign des Prozessorboards dann so zu gestalten das dort die gleichen Signale sind. Dann sollte man mit gewinkelten Pfostensteckern beide Platinen verbinden können. Einzig einen 6poligen Stecker in der Mitte des Leistungteils habe ich dort nicht mehr unterbekommen. Den zu verlegen könnte man noch versuchen, ein Kabel bleibt aber derzeit übrig. Die Stecker sind quasi Pinkompatibel so das das neue Leistungteil auch an den alten Prozessorpart angeschlossen werden kann ohne sich groß zu verrenken.

    Die beiden Fets in der Boardmitte sind der Akkuverpolungsschutz, bzw. sollten es sein. Hm kann ich jetzt nicht checken schaue ich morgen mal drauf.
    Ach so noch was: Weil jetzt auf der Prozessorplatine keine Autoakkueingangsspannung mehr vorhanden ist habe ich diese im Leistungsteil auf einen Stecker gelegt. Ein entsprechender Konterpart fehlt aber gegenwärtig auf der Prozessorplatine.
    Und dann könnte man sich noch das Thema Stepupwandler ansehen, da bin ich nicht ganz sicher ob ich die Signale die ürsprünglich vom Prozessor zum ICL7667 und zurück zur Prozessorplatine gingen noch geroutet habe oder nicht (nachdem da kein Stepdown mehr vorhanden ist braucht man das nicht mehr)
    Wobei mir da neulich noch eine Idee gekommen ist: Vieleicht könnte man die Stepdown Mosfets und die Diode noch auf die linke Platinenseite schieben und die Spule noch etwas in die Mitte ziehen. Die Spule kann ja über den niedrigen SMD Bauteile liegen.

    Müsste man mal schauen
    ... Viel Text....

    Malte
  16. Space

    Space New Member

    Huhu Malte..

    ..reden wir wirklich von dem selben Board oder bin ich zu doof....?

    Vergleich mal den Anhang mit deiner View...

    Attached Files:

    • V2.jpg
      V2.jpg
      File size:
      158.6 KB
      Views:
      73
  17. MalteS

    MalteS Member

    Hi Thomas,

    jepp das passt schon.
    gib mal ratsnest oben in dem Eingabefeld ein oder klick auf den Button in der linken Symbolleiste der wie eine fünf auf dem Würfel aussieht, bei der man die Augen mit Linien verbunden hat.

    Hintergrund:

    Auf dem Board befinden sich insgesamt drei polygone. Die Polygone sind mit einem Signal (2x GND und einmal mit der Eingangspannung) verbunden und fließen quasi um andere Signale herum. Dieses "Herumfließen" führt ratsnest durch. Nach dem öffnen des Boards sieht du diese Polygone allerdings nur als Rechtecke. Sehen da wie Leiterbahnen aus. Es ein Polygon (in rot) auf der Oberseite um die gesamte Platine und zwei auf der unterseite. Eins davon auch wieder fast um die gesamte Platine mit Ausnahme der Fets unten links. Die Leiterbahn die in deinem Bild da vermeindlich durch die Fets geht ist das dritte Polygon.

    Die Polygone sind der Grund warum z.B. bei der Kondensatorarmada jeweils nur ein Bein verbunden zu sein scheint. In Wirklichkeit liegt das andere Bein auf GND. Das sieht man aber erst wenn das Polygon berechnet worden ist.

    Das mit den IRF1404 ist ein Fehler, die müssen in IRF3205 umbenannt werden. Das ist wahrscheinlich dann schon in der ersten Version falsch.

    Überlegst du da mal eine Platine zu machen?

    Hope that helps...

    MAlte
  18. Space

    Space New Member

    Danke für deine ausführliche Erklärung, die hat jetzt geholfen es zu verstehen was Eagle da macht oder besser nicht macht. Warum werden die Polygone nicht sofort ausgerechnet [​IMG]. Am Rechenpower kann das im Jahre 2007 ja nicht liegen...
    Die Erklärung hat aber auch mal wieder bestätigt, daß diese Programm von Leuten entwickelt wird, welche nicht auf dieser Erde leben sondern eine eigene haben, welche voller Drogen sein muss....[​IMG]

    Ich denke schon, das ich dein Layout mal nachbauen werde. Im Moment muss ich aber erstmal einige offenen Baustellen schliessen, bevor ich neu aufmache.
  19. Steffen

    Steffen New Member

    Ich finde das sehr gut, da man dann nicht immer die Masseflächen gefüllt hat. Der Überblick über die gerouteten Leiterbahnen fällt mir da leichter.

    So würde ich also sagen, dass die Entwickler da sehr wohl wussten, was sie tun :)

    Schade, dass ich soviele offene Baustellen habe, sonst würde ich mir auch einen Lader aus dieser Linie bauen. C und Eagle Light finde ich aus vielen Gründen sinnvoller, im besonderen, dass es umsonst ist und auch Gelegenheitsinteressenten mitmachen können.

    Steffen
  20. Frogger

    Frogger New Member

    Ich wollte mal das Basic nach C übersetzen aber hab dann glaub nach 5min aufgehört mit dem kommentar "sch... man ich erfinde hier gerade das Rad neu" als ich auf die Zeilen für das Protokoll zum auslesen der MAX gestossen bin.
    Das ist es aber nicht was ich sagen wollte. Ich hab mit den Eagle Poligonen auch immer so meine Probleme weil ich zu blöde bin. Naja eigentlich nur zu ungeduldig mich da reinzufuchsen. Dann nehme ich immer diese Rechtecke und mach mir da meine Flächen mit. Das sieht dann aus als ob ich nicht bis drei zählen kann aber damit kann ich leben weil es ja auch irgendwie stimmt :)
    Mit target komm ich garnicht klar (hab mich auch noch nie damit beschäftigt) aber habe beim bauen meines Laders einige Funktionen wie die Bauteilsuche oder das Markieren einer Leiterbahn auf dem Layout um sie dann im Schaltbild zu finden (und andersrum) sehr zu schätzen gelernt. Sollt ich mir vielleicht doch mal genauer angucken das ganze.
    Ich laber! :rolleyes:

Share This Page