Discussion in 'Bugs' started by rotormover, Oct 10, 2009.

  1. rotormover

    rotormover New Member

    Hallo Dominik,
    zur Erinerung: CAC1 - war schon ne wilde Aktion damals. Vielleicht erinnerst Du Dich noch. Aktuell habe ich ein Problem beim Auslesen des
    LIPOWATCH. Ich habe das Logfile der Initialisierung mal mitgeschickt.
    Bei 17:04:13,846 erkennst Du den LW_STATUS_ERROR, der dann zum Schluß als Timeout Fehler zum Abbruch führt.
    Wäre schön, wenn DU/IHR mir helfen könntet.
    Gruß Jürgen

    Attached Files:

  2. Dominik

    Dominik Administrator Staff Member

    Moin !

    Einfach noch etwas warten.
    Der LipoWatch ist noch nicht komplett / sauber eingebunden.

    Holger ist dran und wird evtl. hier auch noch kurz was zu schreiben.
  3. rotormover

    rotormover New Member

    Du bist aber wieder schnell, aber das kennt man ja bei euch.
    Danke für die Nachricht. Ich werde also erst mal die Baustelle
    LIPOWATCH schließen und abwarten. Es wäre aber prima, wenn
    ich die vollständige Funktion des LW in LV irgendwie mitkriegen
    würde. Also - laßt es mich wissen.
    Bis die Tage
    FJB
  4. Dominik

    Dominik Administrator Staff Member

    Moin !

    Haben wir jemals was verschwiegen :rolleyes:
    Und Newsletter kommt doch auch wenn ...
  5. Holger

    Holger LogView Team

    Hallo,

    habe schon Fortschritte mit dem LipoWatch erreicht, ist aber noch nicht fertig...

    Gruß, Holger
  6. speedy66

    speedy66 New Member

    hallo holger
    wie weit ist die arbeit am lipowatch vorangeschritten??????
    die arbeit mit dem dazugehörigen excel program ist ein horror!!!!!
    lg
    sigi
  7. Holger

    Holger LogView Team

    Sorry, dauert noch etwas!
    Bin zur Zeit beruflich mal wieder extrem ausgelastet, da eine Produktneuentwicklung, für die ich verantwortlich bin, getestet und zur Serie überführt werden muss.
    Da bleibt leider nicht mehr viel Freizeit.

    Gruß, Holger
  8. Holger

    Holger LogView Team

    So, erste Fortschritte sind gemacht. Das USB-Verhalten war etwas störrisch und die Daten-Dokumentation ist etwas "lückenhaft".
    Aber immerhin kann ich schon Settings auslesen und der Rest kommt dann wohl in den nächsten Tagen.

    Gruß, Holger
  9. Dominik

    Dominik Administrator Staff Member

    Moin !

    Bin auch gespannt wann der "SM-Doktor" Kurven mit dem LipoWatch zaubert :D
  10. Holger

    Holger LogView Team

    Naja, Kurven zaubern ist eigentlich ziemlich einfach und geradeaus.
    Aber Setttings schreiben/lesen unter Beachtung aller Nebenbedingungen und richtiger Interpretation der Dokumentation ist mit einigem Aufwand verbunden.

    Gruß, Holger
  11. Holger

    Holger LogView Team

  12. Holger

    Holger LogView Team

    Abschlussinfo: LipoWatch ist ab V2.6 voll funktionell eingebunden!

    Gruß, Holger
  13. rotormover

    rotormover New Member

    Und funktioniert erstklassig. Endlich muss ich nicht mehr mit excel herumkaspern
    Viele grüße
  14. berols

    berols Member

    LiPo-Watch Timeout-Fehler ?

    :confused:
    Hallo Holger und Dominik,

    habe versucht den LiPo-Watch mit 30 Datensätzen auszulesen und bekomme beim Auslesen den Fehler:
    Timeout/Retry Overflow (siehe Anhang).

    Mit dem Excel-Programm von SM-Modellbau kann ich die 30 Datensätze ohne Probleme einlesen.

    LogView-Version 2.6.2.329
    Betriebssystem : Windows 7

    Könnt ihr helfen ?

    Gruß Bernd

    Attached Files:

  15. berols

    berols Member

    LiPo-Watch Daten auslesen

    Hallo,

    habe weitere Erkenntnisse:

    Treiber auf SM-USB Treiber aktualisiert !

    Datensätze werden jetzt gelesen, aber mit Übertragungsfehler, siehe Anhang.
    Die LED1 des LiPo-Watch leuchtet nach dem Einlesefehler ebenfalls.

    Gruß Bernd

    Attached Files:

  16. Holger

    Holger LogView Team

    Hallo Bernd,

    sehe ich mir morgen Abend an. Bin bis dahin noch unterwegs.

    Gruß, Holger
  17. Holger

    Holger LogView Team

    Hallo Bernd,

    hättest Du die Möglichkeit, mit Deiner Hardware mal zu prüfen, ob das irgendwie ein Win7-spezifisches Problem ist?

    @all
    Gibt es auch von anderen Usern negative Erfahrungen mit hoher Fehlerzahl und/oder Win7?

    Gruß, Holger
  18. berols

    berols Member

    Hi Holger,

    werde morgen mal auf meinem alten XP-Rechner testen, muß aber erst die letzte LogView-Version 2.6.2.329 aufspielen.

    Habe die 30 Datensätze vorsorglich im LiPo-Watch noch nicht gelöscht.
    Im SM-Excel Programm kann ich noch folgendes auslesen:
    Speicherbelegung 67%. LiPoWatch Firmware v1.00

    Gruß, Bernd
  19. berols

    berols Member

    LiPo-Watch, Daten auslesen

    Hallo Holger,

    habe heute mal ein ein bißchen "rumgetestet":

    Beide Rechner XP und Win7 benutzen den gleichen USB-Treiber von SM-Modellbau
    und auf beiden ist die die letzte LogView-Version installiert.

    Der XP-Rechner liest die 30 Datensätze ohne Fehler in 3'45" ein, der Win7-Rechner benötigt dafür ca. 10 Minuten und zeigt bei mehreren Versuchen eine unterschiedliche Anzahl von Übertragungsfehlern an.
    Beim Versuch, danach die ToolBox zu schließen, hängt sich der Rechner regelmäßig auf: Keine Rückmeldung ToolBox.

    Beim XP-Rechner scheinen die Rx-und Tx-LED von Logview im Dauerbetrieb zu sein und zucken nur kurz dunkel. Beim Win7-Logview-Betrieb (Tx, Rx-LED) sieht das Datenauslesen eher träge aus.

    Der CHECK-Button der ToolBox ergibt auch nicht sofort ein Ergebnis, erst beim zweiten Öffnen erscheint die Firmware-Version und die Serien-Nr., die Speicherbelegung manchmal.

    Es wurden mehr Bytes beim XP gelesen als vorhanden, evtl. verifiziert ? (siehe Bild XP-Rechner)

    Die Anzeige der Belegung des Speichers wird wohl in LogView anders interpretiert als im Excel-Programm von SM: 33% bzw. 67% ?

    Holger, vielleicht kannst Du ja anhand der Bilder schon mal eine Analyse machen, stehe für Nachfragen gerne bereit.

    An alle: Falls jemand mit Win7 und Lipo-Watch/LogView keine Probleme beim Auslesen der Daten hat, wäre es nett, wenn er seine Konfiguration mal posten würde.

    Vielen Dank

    Gruß, Bernd

    Attached Files:

  20. berols

    berols Member

    LiPoWatch Tool-Box schliessen: Fehler

    :confused:
    Hallo Holger,

    da sich zu diesem Problem seit längerem nichts tut, hier ein paar neue Erkenntnisse von mir:

    Das Auslesen des LiPoWatch mit Win7 klappt jetzt ohne Fehler. Immer noch fatal ist die Tatsache, dass beim Schließen der LiPoWatch-Toolbox, sich das System aufhängt, weil über den COM-Port keine Rückmeldung kommt. Auch beim Setzen (Tx) des LiPoWatch das gleiche. Es werden dann die 2 Kontroll-LEDs des LiPoWatch sofort gelöscht.
    Beim Datentransfer mit dem UniLog von SM funktioniert mit dem gleichen System, USB-Interface und Treiber alles ohne Fehler.
    Vermute das Problem beim Handshaking (Tx) mit dem LiPoWatch (Tool-Box) bei Win7-Betriebssystem.


    Gruß Bernd

    Attached Files:

Share This Page