Discussion in 'Bugs' started by jochene, Sep 13, 2009.

Thread Status:
Not open for further replies.
  1. jochene

    jochene New Member

    Hallo Holger,

    vielen Dank für die "Blumen".

    Wenn es dich interessiert, es gibt noch ein auf das Telemetriesystem aufbauendes Projekt.

    Infos dazu gibt es hier:
    http://www.modellheliflieger.de/joo...ent&view=category&layout=blog&id=44&Itemid=83

    oder beim Wilhelm:
    http://www.toeging.lednet.de/flieger/profi/lipovolt/lipovolt.htm

    Neben dem Telemetriesystem sind noch weitere Funktionen implementiert. Neuerdings sogar noch eine Datenaufzeichnung auf SD-Karte. Die aufgezeichneten Daten können dann auch wieder mit Logview ausgewertet werden.

    Und natürlich alles OpenSource.

    Hoffe, das das Problem mit den verschluckten Bytes nicht schwierig zu finden ist.

    Gruss
    Jochen
  2. Holger

    Holger LogView Team

    Hallo Jochen,

    So, das Problem ist eindeutig gefunden und schon behoben.
    In bestimmten Situationen wurde tatsächlich das letzte Byte der noch im Puffer stehenden Daten nicht mitgenommen.

    Bei der kritischen Durchleuchtung der Auswerteroutinen ist mir nebenbei aufgefallen, dass da bezüglich Störsicherheit und Resynchronisierung noch Verbesserungspotential drin steckt. Daran arbeite ich gerade. Gerade für Funkstrecken könnte das einiges an Verbesserungen bringen.

    Gruß, Holger
  3. jochene

    jochene New Member

    Hallo Holger,

    Du (natürlich Ihr) seid einfach nur super super super.

    Danke

    Gruss
    jochen
  4. Holger

    Holger LogView Team

    OF-Empfangsroutinen verbessert

    Hallo Jochen,

    nochmals Danke!

    Die Empfangsroutinen sind nun überarbeitet und funktionieren bei Tests bisher sehr gut. Man kann nun mit Clustersize von -1 bis ca. -10000 sauber empfangen.
    Clustersize = -90 sollte aber in dem Fall der Telegrammlänge die besten Ergebnisse im zeitlichen Verhalten in LV bringen und beibehalten werden.

    Alle Zeichen bis zum Empfang eines Startzeichens '$' werden generell verworfen, so dass auch kein evtl. Empfangspufferüberlauf bei permanent falschen Zeichen mehr vorkommen kann.
    Auch Daten, die zwar durch Startzeichen eingeleitet, aber nicht durch <CR><LF> abgeschlossen sind, werden beim nächsten Empfang eines Startzeichens verworfen.

    Die Verbesserungen betreffen alle direkt auf dem OpenFormat basierenden Geräte.

    Noch eine Frage: In der ini habt ihr
    ...
    Messgröße10 = Drehzahl
    Einheit10 = Upn
    ...
    eingetragen. Sollte das evtl. Upm heißen?

    Gruß, Holger
  5. jochene

    jochene New Member

    Hallo Holger,

    ups, .... Du hast Recht.

    Es fangt nun wohl doch die Zeit an, wo ich die Brille aufsetzen sollte.:cool:

    Werde unsere INI dann wieder auf -90 setzen.

    Danke

    Gruss
    Jochen
  6. wkrug

    wkrug New Member

    Genauso hab ich das bei unserem Telemetriesystem auch geproggt - Da sollte es also keine Probleme mehr geben.

    Ich muß mich Jochen anschließen - Ihr seid Super!!!
  7. Holger

    Holger LogView Team

    Hallo,

    hattet Ihr denn schon Gelegenheit, mit der aktuellen LV-Version (mit bereinigtem OF-Empfang) die Telemetrie zu testen?
    Wenn alles OK ist, könnte ich Jochen ja die Telemetrie wieder zurücksenden.

    Gruß, Holger
  8. wkrug

    wkrug New Member

    Ich hab die aktuelle LV Version noch nicht installiert.

    Ich hoffe, das Jochen das übernimmt - Werd Ihn mal kontaktieren.
  9. jochene

    jochene New Member

    Hallo Holger,

    hatte in den letzten Tagen die neue LogView Version noch nicht testen können (aber schon installiert).

    Auch das behobene Problem mit dem Akkumatik konnte ich noch nicht ausprobieren.

    Ich hoffe, das ich heute abend dazu komme - werde mich melden.

    Ihr könnt den Sender und Empfänger aber auch gerne bei Euch behalten.

    Gruss
    Jochen
  10. Holger

    Holger LogView Team

    Aaaah, na dann ist ja alles gut! Danke!
    Und ich hatte schon ein bischen schlechtes Gewissen, dass ich die Teile noch nicht zurückgesendet habe! :rolleyes:

    Gruß, Holger
  11. jochene

    jochene New Member

    Hallo Holger,

    sorry für die verspätete Rückmeldung.

    Das Openformat funktioniert nun einwandfrei - super und Danke.

    Übrigens, der Akkumatik funktioniert nun auch super
    - gleichzeitiges Laden über A1 und A2 mit Balancer LBA10 und LipoCheckerPro

    Vielen Dank

    Gruss
    Jochen
  12. Gewächshauslogger

    Gewächshauslogger New Member

    Hallo Jochen!
    Ich bin neu mit logview - und möchte "alte" Loggerdateien, die im ASCII Format voliegen improtieren - da lese ich etwas von "IMPORTIEREN"
    Also nicht direkt von einem Gerät per Schnittstelle, sondern aus einer Datei, wo die Daten stehen wie sie vom Logger kamen:
    29.06.08 17:38:57 730 10.19 1019 0 0
    29.06.08 17:39:07 731 10.19 1019 0 0
    29.06.08 17:39:17 15 10.19 1019 0 0
    29.06.08 17:39:27 50 10.19 1019 0 0
    29.06.08 17:39:37 81 10.19 1019 0 0
    29.06.08 17:39:47 109 10.19 1019 0 0
    29.06.08 17:39:57 136 10.19 1019 0 0
    29.06.08 17:40:07 161 10.19 1019 0 0
    29.06.08 17:40:17 186 10.19 1019 0 0

    mit welchen Befehlen geht das?
    wäre für eine Hilfe überaus dankbar!
    Gruß
  13. jochene

    jochene New Member

    Hallo Gewächshauslogger,

    im Logview gibt es unter "Datei" den Punkt "Gerätedatei importieren".

    Damit kannst Du Logdateien importieren.

    Ob das mit Deinem Logformat funktioniert, kann ich Dir leider nicht sagen - probiere es doch einfach mal aus.

    Auf der Logviewseite und im Logview (ich glaube Openformateditor) ist das Openformat beschrieben.

    Gruss
    jochen
Thread Status:
Not open for further replies.

Share This Page