Discussion in 'Bugs' started by h2omeister, Mar 15, 2008.

Thread Status:
Not open for further replies.
  1. h2omeister

    h2omeister New Member

    Ich habe mit dem Unilog einen Datensatz mit 7984 Wertesätzen erfaßt, die sich mit UniLog Excel v1.05.xls problemlos auslesen lassen.
    UniLog Firmware v1.06 (SN 19084)

    Logview 2.0 liest jeweils nur einen Teil der Wertesätze aus (max. 3200 von 7984).

    Gruß
    Hermann

    Datei mit Bildschirmgrafiken = Unilog-Logview_080315.doc

    Attached Files:

  2. Holger

    Holger LogView Team

    Hallo Hermann,

    wie in meiner direkten email-Antwort an Dich ja schon geschrieben, werde ich mir die Sache mal näher ansehen und hoffe, das nachstellen zu können. Bisher kenne ich diesen Effekt aber noch nicht.

    Ich vermute mal Probleme bei der Datenübertragung über das USB-Interface.

    Gruß, Holger
  3. stefimat

    stefimat Member

    Hallo zusammen
    So ist es.
    Ich kenne den Effekt auch, wenn ich am gleichen USB-Hub
    auch noch den Lader dran hängen habe.
    => es geht nur entweder Lader oder Logger.
    (allerdings kann es sein dass es bei mir daran liegt, da es bei mir eine sehr lange USB-Strecke ist. Diese besteht aus zwei USB-Hubs (beide Aktiv durch Netzteile versorgt))

    Allerdings ist dieser effekt mit der neuen Version deutlicher geworden.
    Jetzt kommt es auch schon mal vor (aber selten), daß LogView abbricht, bevor das Ende Erreicht ist, auch wenn nur der Logger dran ist.

    CU l8er Stefan
  4. Dominik

    Dominik Administrator Staff Member

    Moin !

    Ich möchte hier nur mal kurz erwähnen, das die Datenbehandlung eigentlich gleich ist. Da haben wir in der 2.0 nichts umgebaut.

    Die Darstellung hat sich zwar grundlegend geändert, aber die "Core" Verarbeitung und mehr oder minder gleich zur 1.xx
  5. stefimat

    stefimat Member

    Hallo Dominik,
    Das glaube ich Dir gerne, ich wollte auch auf keinen Fall die Version 2 kritisieren. Es ist mir nur so aufgefallen.
    Aber eben, daran bin ich schuld, denn die beiden verketteten USB Hubs gegen quer durchs Büro, dann in die Werkstatt...
    Also weit über dem was zugelassen ist!

    Da ich ja mein alten MultiProfi CAC-1 nun auch über Logview aufzeichnen kann,
    => noch mal Danke an der Stelle!!! <==
    der ist über eine reine serielle Schnittstellenleitung mit noch viel viel mehr Länge (5 ganz lange Kabel sind jeweils gekoppelt) verbunden.
    Der geht immer parallel zum (USB-Lader) oder Logger.

    Ihr könnte sicherlich nicht das richten, wenn ich (der User) die Daten
    schlecht anliefert!

    CU l8er Stefan
  6. Holger

    Holger LogView Team

    In diesem Fall ist ja nur merkwürdig, dass es wohl mit UniLog Excel v1.05.xls problemlos funktioniert!? :confused:

    Gruß, Holger
  7. stefimat

    stefimat Member

    Stimmt, problemlos kann ich zwar nicht sagen, aber
    es geht "eher". Aber das Excel-tool ließt deutlich langsamer!
    Eventuell liegt es daran!

    CU l8er Stefan
  8. Holger

    Holger LogView Team

    Aha, Danke für die Zusatzinfo! :)

    Gruß, Holger
  9. h2omeister

    h2omeister New Member

    Zusatzinfo.
    Bei mir ist der Unilog direkt mit dem USB-Interface von SM-Modellbau am PC angeschlossen.
    Die deutliche langsamere Datenübertragung mit UniLog Excel v1.05.xls ist mir auch aufgefallen.

    Gruß

    Hermann
  10. Holger

    Holger LogView Team

    Tja, ich bekomme hier keine Fehler provoziert. Auch bei zigmaligem Auslesen von 20000 Wertesätzen funktioniert alles problemlos.

    Das ist bei meinem System nicht wirklich sichtbar. Bei mir werden die kompletten Daten (20063 Wertesätze) innerhalb von ca. 102 s ausgelesen, unabhängig von LogView oder xls-Sheet 1.05. Etwaige Differenzen liegen im Bereich weniger Sekunden.

    Wie liegen da die Zeiten bei Euch in etwa?

    Es sieht so aus, als ob da bei Euch wirklich die Datenübertragung gestört ist und etliche retries notwendig sind, die Daten ranzuholen.
    Ich habe mich bei der Umsetzung des retry- und error-handlings eigentlich genau an Vorlage gehalten, werde das aber noch mal genau prüfen.
    Evtl. muss ich mir sogar mal einen Fehler-Simulator schreiben, um das Problem künstlich herbeizuführen.

    Ist das eigentlich bei Euch regelmäßig ein Problem oder nur bei bestimmten Aufzeichnungen?

    Gruß, Holger
  11. h2omeister

    h2omeister New Member

    :)Hallo,

    es scheint bei mir ein Problem der Datenübertragung zum PC zu sein:confused:.

    Bei meinem Laptop funktioniert die Übertragung einwandfrei.
    Ich werde mal weitersuchen.

    Gruß
    Hermann
  12. Holger

    Holger LogView Team

    Hallo Hermann,

    mit Hilfe der Debug Konsole werden wir das Problem schon einkreisen können! :)

    Gruß, Holger
  13. stefimat

    stefimat Member

    Hallo Holger,
    Upss, da liegen ja Welten dazwischen!!!

    Nun, da habe ich mal mehrere Messungen gemacht.
    1. Sind es bei mir bei 100 % Messpeicherausnutzung immer 25920 Datensätze.

    => Erster Versuch:
    ==============
    zwei UniLogs (L1 und L2) sind parallel im Flug (zwei Flüge) gelaufen.
    => 25920 Datensätze:

    Auslesen mit EXCEL-Tool V1.05:
    sowohl bei Logger L1 als auch bei L2 jeweils
    zwischen 6 Min. 55 Sec. und 6 Min. 57 Sec. (4 Messungen)

    Logview:
    Logger L1: 8 Min. 04 Sec. bzw. 8 Min. 05 Sec.
    Logger L2: 8 Min. 25 Sec. bzw. 8 Min. 24 Sec.

    Beachtenswert: Logger L1 hatte einen Fehlerhaften Datensatz.
    => Exceltool ordnet diesen Flug 1 zu => Flug nicht auswertbar.
    Logview macht 3 Messungen daraus.
    1. Messung = 1. Flug => OK
    2. Messung = Fehlerhafter Datensatz
    3. Messung = 2. Flug => OK

    Weiterhin fällt auf, da während dem Auslesen mit dem EXCEL-Tool
    keine LED's des UniLog leuchten.
    Beim Auslesen mit Logview blinkt die rote LED des UniLog immer
    rytmisch: lang rot, kurz aus, lang rot, kurz aus...


    => zweiter Versuch:
    ===============
    zwei UniLogs (L1 und L2) sind erneut parallel im Flug (zwei Flüge) gelaufen.
    => 25920 Datensätze:

    Auslesen mit EXCEL-Tool V1.05:
    sowohl bei Logger L1 als auch bei L2 jeweils
    zwischen 6 Min. 55 Sec. und 6 Min. 56 Sec. (4 Messungen)

    Logview:
    Logger L1: 7 Min. 18 Sec. bzw. 7 Min. 19 Sec.
    Logger L2: 6 Min. 45 Sec. bzw. 1 x Abbruch

    ebenso:
    Beim Auslesen mit Logview blinkt die rote LED des UniLog immer
    rytmisch: lang rot, kurz aus, lang rot, kurz aus...

    => dritter Versuch:
    ===============
    zwei UniLogs (L1 und L2) sind erneut parallel im Flug (ein Flug) gelaufen.
    nur 55 % ausgenützt => 14307 Datensätze:

    Auslesen mit EXCEL-Tool V1.05:
    sowohl bei Logger L1 als auch bei L2 jeweils
    zwischen 3 Min. 51 Sec. und 6 Min. 53 Sec. (4 Messungen)

    Logview:
    Logger L1: 3 Min. 58 Sec. (zwei Messungen)
    Logger L2: 3 Min. 42 Sec. bzw. 3 Min. 46 Sec.

    diesmal:
    Beim Auslesen mit Logview leuchtet die rote LED des UniLog immer
    (zumindestens für mich ohne sichtbare Unterbrechung!).

    Wie schon mal oben beschrieben, dies in allen Fällen über die
    doppelt kascadierten aktiven USB-Hubs.

    Fazit:
    Ich dachte immer Logview ist immer schneller (war es eventuell in der vorigen Version auch???) so kann man sich teuschen!!
    Allerdings, Logview analysiert auf jeden Fall besser!! (siehe Versuch 1)

    CU l8er Stefan
  14. Holger

    Holger LogView Team

    Hallo Stefan,

    sehr interessante Ergebnisse! :eek:
    Ich werde das mit dem Kaskadieren mal testen...

    Bin gespannt, was andere so dazu schreiben! Ob eher meine Zeiten oder eher Deine bestätigt werden!

    Gruß, Holger
Thread Status:
Not open for further replies.

Share This Page