Discussion in 'Bugs' started by Akkufritze, Oct 8, 2009.

Thread Status:
Not open for further replies.
  1. Akkufritze

    Akkufritze New Member

    ein nettes hallo
    habe bisher logview eingesetzt und war überaus zufrieden. bisher hatte ich unten links immer ein fenster mit den livedaten, ist unter anderem hilfreich, wenn man genaue zahlen braucht. seit der neuen version kann ich das nicht mehr aufrufen und habe nur noch die grafik. es kommt halt die fehlermeldung, keine gültige layoutdatei. wer kann mir bitte helfen. verwendet wird ein akkumatik.
    mfg. akkufritze
  2. Akkufritze

    Akkufritze New Member

    anscheinend habe ich wohl nur das problem, warum auch immer.
    wäre nett, wenn mir jemand sagen kann, wo ich die älteren versionen finde, aber schon ab der zweier, die haben ja funktioniert.
    mfg. akkufritze
  3. Dominik

    Dominik Administrator Staff Member

    Moin !

    Ok, geh in dein Userverzeichnis von LogView. Bei mir ist das:
    %LW%:\Documents and Settings\%USER%\Application Data\LogView

    Hier lösche mal DesktopDefault.lvd und DesktopWork.lvd.

    Jetzt in den Ordner Templates Desktop.

    Dort lösche mal alle befindlichen Dateien.

    Jetzt starte LogView. Dann legt er neue Default Templates an.

    Hintergrund:
    Wir haben in LogView 2.5 das Layout geändert. Das bedingt das diese Dateien ausgetauscht werden. Und normalerweise sollte das LogView beim ersten Start automatisch löschen und dann aktualisieren.
  4. Akkufritze

    Akkufritze New Member

    danke für die antwort, aber die situation ist unverändert.
  5. Dominik

    Dominik Administrator Staff Member

    Moin !

    Dann bleibt dir nur Hardcore ...


    • LogView beenden

    • Im LogView Installationsordner (C:\Programme\....) gibt es auch die Dateien:
      - DesktopDefault.lvd
      - ggf. DesktopWork.lvd

      Diese löschen.

    • Und falls LogView hier schon neue hinkopiert hat: %LW%:\Documents and Settings\%USER%\Application Data\LogView
      die auch nochmal löschen.
    • LogView starten
    Danach hast du dann kein Layout mehr. Sprich es ist alles an was es in LogView gibt. Du musst dann halt die für dich unnützen Panel wegklicken. Aber das ist nur eine Sache von Sekunden.
    Danach sollte LogView den eingestellten Stand merken.

    Wenn dann immer noch nix geht, dann hast du vermutlich ein Schreibproblem in deinem Userverzeichnis.
  6. Akkufritze

    Akkufritze New Member

    ok, hat erstmal super geklappt und bedanke mich für die antwort.
    noch zwei sachen, die mich jetzt interessieren, aber nicht sooo wichtig sind.
    das livedatenfenster konnte man früher frei verschieben und es war auch original links unten. jetzt ist es fix, rechts neben dem grafikfenster, läßt sich das ändern?
    und die zweite sache, wenn ich den rechner neu starte und das datenkabel seriell am lader hängt, kann er anschliessend den port nicht öffnen.
    ich muß beim pc start immer das datenkabel raushaben und das vergisst man manchmal, hat das eine ursache?
    auch hier für die antworten schon mal dank.
    mfg. akkufritze
  7. Dominik

    Dominik Administrator Staff Member

    Moin !

    Im Moment nicht. Wir haben jedem Fenster eine feste Position gegeben. Das hat vornehmlich damit zu tun, das es mit den frei verschiebbaren Fenstern öfter mal Stress gab.
    Wir sind aber am überlegen eine Funktion einzubauen um die Seite zu verändern.
    Aber generell ist es schon gewollt das LV 2.5 etwas "statischer" im Aufbau ist. Das erhöht doch die Stabilität wie wir festgestellt haben.

    *Glaskubel raushol* Du hast sicher einen Quadrillenbeschleuniger in Betrieb, oder *Glaskugel wegpack*
    Ich habe keinen schimmer was du für einen Lader hast - gescheigedenn welcher USB / Seriell Adapter da dran ist / verbaut ist.
    Ich vermute mal das es ein SiLabs Chip ist ...

    Dazu gibt es hier schon einige Posts:
    http://www.logview.info/vBulletin/forumdisplay.php?f=39

    Sollten Die Infos da nicht reichen bitte dort einen neuen Post erstellen. Denn sonst wird das hier arg offtopic.
  8. Akkufritze

    Akkufritze New Member

    das mit den fenstern ist dann ok

    aber wieso glaskugel
    im ersten posting steht bereits, das ein akkumatik drannhängt
    und ansonsten sprach ich vom seriellen port, was bei mir immer noch com1 oder 2 ist, grübel.
  9. Dominik

    Dominik Administrator Staff Member

    Moin !

    Sorry, übersehen. Man möge mir verzeihen. :rolleyes:

    Hmm, das ist allerdings dann merkwürdig. Also aus LogView Sicht spielt es eigentlich keine Rolle ob der Lader dran ist oder nicht. Denn es erfolgen keine direkten Zugriffe auf den Port. Beim Start wird nur nachgesehen welche Ports vorhanden sind.
    Erst beim Öffnen des Ports erfolgt dann wirklich ein Zugriff.

    Bedeutet ...

    • entweder hast du ein Problem mit deinen seriellen Ports am Rechner (Defekt, Treiber, ...)
    • oder eine andere Anwendung / dienst blockt ggf. den Port?!
    Ich kann das heute Abend aber gerne mal eben testen wie es sich bei mir verhält. Melde mich dann später dazu nochmal.
  10. BlackVara

    BlackVara New Member

    Hallo zusammen,

    dies ist nun mein erster Beitrag. Da die Probleme erst mit der Version 2.5.0.253 erstmalig auftreten.

    Ich habe das gleiche Problem wie hier im Betrag geschildert von Akkufritze.
    Habe dann auch die von Dominik vorgeschlagen Möglichkeiten ausprobiert, doch leider führte keine von diesem zum Erfolg. Es kommt noch immer "Keine gültige Layout Datei"

    Nun zu meinem System und dem was ich bisher versucht habe.
    - Windows Vista
    - .lvd liegt unter C:\Users\%UserName%\AppData\Roaming\LogView
    - Komplette Deinstallatiion und Neuinstallation
    - Speichern von eigenen Ansichten ist möglich, die anschliessende Auswahl auch

    Für weitere Vorschläge bin ich offen...

    Andreas
  11. Dominik

    Dominik Administrator Staff Member

    Moin !

    Das kommt dann wenn die Datei eben nicht mehr gültig ist - wir erinnern uns ... In 2.5 haben wir die Layout Dateien geändert (für die Oberfläche).

    Ich möchte wetten das du nicht alle alten *.LVD Dateien gelöscht hast, oder aber du versuchst eine alte LVD von dir zu laden.

    Starte mal aus dem Startmenü -> LogView V2 -> Tools -> Cleanup.
    Und in dem CleanUp klicke auf den obersten GO Button. Dann öffnet er das Userverzeichnis mit dem LogView arbeitet.
    • LV beenden wenn gestartet
    • lösche hier alle *.LVD Dateien
    • lösche alle *.LVD Dateien im Ordner \Templates Desktop
    • lösche alle *.LVD Dateien in deinem LogView Installationsordner
    • LV starten -> Oberfläche anpassen -> LV beenden -> alles ok ;)
  12. BlackVara

    BlackVara New Member

    Hi Dominik,

    leider muss ich dir wiedersprechen. Bei meiner Deinstallation, habe ich nach der automatischen deinst. des Installers alle noch vorhandenen LogView Ordner und Dateien gelöscht!

    Nun hab ich es noch mal so gemacht wie du es beschrieben hast und wirklich alle *.LVD Datien gelöscht.
    Ja, beim Neustart werden alle Fenster angezeigt, habe alle bis auf das Hauptfenster geschlossen, dann LogView geschlossen und wieder geöffnet

    ...und siehe da... der Fehler ist immer noch vorhanden..."ratlos bin"

    Die neuen *.LVD´s werden mit Datum 05.10.2008 bei mir erstellt???? Ist das so richtig? Ausser die DesktopWork.lvd die bekommt ein aktuelles Datum

    Und was nun?

    Andreas
  13. Dominik

    Dominik Administrator Staff Member

    Moin !

    Kann ich mir nicht so gant vorstellen.

    Wie schon zuvor geschrieben. Der Fehler kommt nur wenn alte Files vorhanden sind. Man kann das auch leicht mit einem Texteditor kontrollieren.

    Öffne die LVD Datei (für den Start ist wichtig DesktopWork.lvd).
    Eine alte Datei ist ein Binärklumpen und am Anfang steht "LogView Desktop".
    Eine neue Datei hat am Anganf "LogView Desktop Layout V2" stehen.

    Und der Fehler kommt nur wenn die Datei
    a) nicht lesbar oder
    b) falsch oder veraltet ist.

    Insofern muss irgendwo noch eine Alte Datei rumfliegen.

    Attached Files:

  14. BlackVara

    BlackVara New Member

    Hi,

    hab das geprüft was du vorgeschlagen hast und bei mir ist das neue Format in der DesktopWork.lvd vorhanden, am Anfang mit "LogView Desktop Layout V2"

    Schreibrechte der Datei alle eingetragenen Vollzugriff.

    Also noch mal alles Deinstalliert(mit LogView Deinst.) alle danach noch vorhandenen LogView Ordner und *.LVD Dateien gelöscht. Wirklich alle, Vista Suche auf C:\ hat kein Ergebniss mehr geliefert.

    Neuinstallation durchgeführt, Programm gestartet, Initial durchlaufen, Ansicht Wechsel auf z.B. Livedaten versucht -peng-

    Fehler wieder/immer noch da. :confused:

    Andreas
  15. Dominik

    Dominik Administrator Staff Member

    Moin !

    Öhm nutzt du die Default Layout (1-6) die mit LogView kommen?

    Mir ist eben aufgefallen das die veraltet und noch nicht auf aktuellen Stand sind.
  16. BlackVara

    BlackVara New Member

    Hi,

    JA

    Hatte ich vorher erwähnt
  17. Dominik

    Dominik Administrator Staff Member

    Moin !

    Ok, dann kann das nicht gehen. Warte aufs nächste Update.

    Workaround:
    Eigenes Layout erstellen und speichern.

    Schon. Hatte das nur anders verstanden. Ich dachte er hätte das Default Layout mit altem Datum gespeichert. Hatte mich schon gefragt was da schief geht ...
    Sorry.
  18. BlackVara

    BlackVara New Member

    Hi,

    Danke

    Da ist der Fehler ja wenigstens gefunden.
  19. Holger

    Holger LogView Team

    Hallo Akkufritze,

    Nun ja, das hat mit Sicherheit eine Ursache. ;)
    Ich habe heute relativ viel mit dem Akkumatik hantiert und extra etliche PC-Neustarts gemacht, kann das Problem aber nicht nachvollziehen.
    Bei mir ist der Akkumatik an COM1, realisiert über eine PCI-Karte, da mein neues Mainboard kein COM1 mehr an Board hat.

    Ich hatte das von Dir beschriebene Problem lediglich bei Verwendung von virtuellen COM-Ports, zuletzt beim E1. Benutzt Du evtl. einen USB-Adapter zum Anschluss des Akkumatik?

    Gruß, Holger
Thread Status:
Not open for further replies.

Share This Page