Discussion in 'Bugs' started by FlyHein, Jun 8, 2008.

Thread Status:
Not open for further replies.
  1. FlyHein

    FlyHein New Member

    Hallo Zusammen

    Ich nutze seit ein paar Tagen ein Akkumatik 1.2.
    Zum Datenloggen nutze ich einen HAMA USB-Serial Konverter unter Windows XP. Dieser ist auch im Gerätemanager unter Anschlüsse (COM und LPT) als "Profilic USB to Serial Comm Port Profilic" eingetragen.
    Mir ist es auch schon gelungen, Daten vom Akkumatik zu loggen. Allerdings erscheint beim Anschliessen des USB-Serial Konverters an den Laptop hin und wieder der Fehler "ComPort kann nicht geöffnet werden!".
    Weiss jemand Rat?
  2. gunnark

    gunnark Member

    Moin,

    evtl kann es daran liegen das Du nicht immer die gleiche Buchse für den USB - Stick verwendest. Das System ordnet dann jeder Kombination Buchs - USB - Stick einen eigenen COM-Port zu ...

    Dann brauch es ja immer noch einen Moment bis es sich im System rumgesprochen hat das jetzt der Stick eingesteckt ist.

    Evtl hast Du auch noch irgendeine Software installiert die zyklisch alle Ports öffnet und nachschaut ob sich da was interessantes finden läßt.

    Gruß

    Gunnar
  3. FlyHein

    FlyHein New Member

    Fehler - ComPort kann nicht geöffnet werden!

    Hallo Gunnar,

    Danke für deine Antwort.
    Wenn ich die USB-Schnittstelle wechsele, erkennt LogView dies schon. Wenn ich dann die Aufzeichnung starte, erscheint besagte Fehlermeldung.

    Zwischenzeitlich hab ich festgestellt, daß nach erneuter Treiberinstallation des HAMA USB-Serial Konverter der ComPort wieder zur Verfügung steht und damit ein Loggen möglich ist.

    Ich habe nur keine Lust, vor jedem Loggen immer die Treiber installieren zu müssen.
  4. Dominik

    Dominik Administrator Staff Member

    Moin,

    und du hast dir auch mal den aktuellen Treiber besorgt?

    Ich schreibe gerade einen längeren Artikel zu den SiLabs Adaptern ... Da gibts auch sehr lustige Effekte.

    Nebenbei erwähnt ist es kein LV Fehler. ;)
  5. gunnark

    gunnark Member

    Moin,

    naja so ganz kann ich Dir nicht folgen ...

    Also wenn ich den Stick immer an die gleiche Buchse anstecke hat der Stick auch immer den gleichen, bei dem Gerät eingestellten COM-Port. Dann und genau dann.

    Wenn ich eine andere Buchse am Rechner nehme muß ich die Treiber neu installieren.

    Das ist aber alles ein Problem von Windows - da kann Logview nix an tun.

    Ich gehe mal davon aus das Du als Admin angemeldet bist. Sonst kann es sein das die Einstellungen nicht gespeichert werden.

    Ansonsten sieh Dich noch mal nach neuen Treibern um.

    Gruß

    Gunnar
  6. jjKlaus

    jjKlaus New Member

    Fehler - ComPort kann nicht geöffnet werden!

    Hallo FlyHein,

    ich verwende für dasgleiche Problem folgenden workaround:
    Im Windows-Gerätemanager den Anschluss deaktivieren und anschliessend wieder aktivieren.
    Funktionierte bisher immer und ist ein wenig schneller als den Treiber neu zu installieren.

    Zum Gerätemanager kommst Du unter Start->Einstellungen->Systemsteuerung->System->Hardware->GeräteManger. Rechtsklick auf den entsprechenden Anschluss (Identifikation über COM-port) und bei erstenmal "Deaktiveren", beim zweitenmal "Aktivieren" selektieren.

    Grüße

    Klaus

    Attached Files:

Thread Status:
Not open for further replies.

Share This Page